Beantwoord

PPPOE verbinding met eigen router komt niet tot stand

  • 15 June 2024
  • 7 reacties
  • 113 keer bekeken

Hoi ik wil mijn eigen firewall neerzetten en het box 12 modem er tussen uit halen. Ik ben al door alle instucties gelopen zoals 
https://www.kpn.com/service/eigen-apparatuur en diverse gesprekken op forums.

Dit is mijn situatie: Ik heb het bestaande koppelpunt (fiber naar ethernet) intakt gelaten. Ik heb een proxmox hypervisor met daarop pfsense. Ik heb netjes VLAN 6 geconfigureerd op de WAN poort en deze doorgezet naar pfsense. Ik heb alleen maar internet, geen TV of bellen. Onderstaand met netwerk interface vanuit Proxmox.

 

oot@pve:~# 
root@pve:~# cat /etc/network/interfaces
# network interface settings; autogenerated
# Please do NOT modify this file directly, unless you know what
# you're doing.
#
# If you want to manage parts of the network configuration manually,
# please utilize the 'source' or 'source-directory' directives to do
# so.
# PVE will preserve these directives, but will NOT read its network
# configuration from sourced files, so do not attempt to move any of
# the PVE managed interfaces into external files!

auto lo
iface lo inet loopback

iface eno1 inet manual
        mtu 1512

iface enp1s0 inet manual

auto eno1.6
iface eno1.6 inet manual
        mtu 1512
#ISP VLAN 6

auto vmbr_WAN
iface vmbr_WAN inet manual
        bridge-ports eno1.6
        bridge-stp off
        bridge-fd 0
        bridge-vlan-aware yes
        bridge-vids 2-4094
        mtu 1508

auto vmbr_LAN
iface vmbr_LAN inet static
        address 10.100.0.10/16
        bridge-ports enp1s0
        bridge-stp off
        bridge-fd 0

source /etc/network/interfaces.d/*
root@pve:~# 

 

Als ik een tcpdump instel op VLAN 6 op de proxmox server op de wanpoort zie ik keurig PADI verkeer vertrekken. Ik heb PPPOE geconfigureerd met internet/internet als username en password

root@pve:~# tcpdump -i eno1 -vvv vlan 6
tcpdump: listening on eno1, link-type EN10MB (Ethernet), snapshot length 262144 bytes
08:55:37.275434 PPPoE PADI [Host-Uniq 0x00FF933A00F8FFFF] [Service-Name "internet please!"]
08:55:41.305719 PPPoE PADI [Host-Uniq 0x80F3933A00F8FFFF] [Service-Name "internet please!"]
08:55:43.371855 PPPoE PADI [Host-Uniq 0x80F3933A00F8FFFF] [Service-Name "internet please!"]

 

Ik heb de fiber naar ethernet converter een tijdje spanningsloos gemaakt. Ik heb ook geprobeerd om dit met en zonder unmannaged switch er tussen te zetten. Heeft iemand een idee? zie ik iets over het hoofd?

 

icon

Beste antwoord door Nick83 20 June 2024, 20:15

Bekijk origineel

7 reacties

Reputatie 7
Badge +20

Hi @PrivateBungo, wat jammer dat het ondanks al je inspanningen nog steeds niet goed gaat 😕

Dit is iets dat volledig buiten onze ondersteuning valt, dus ik kan er zelf weinig over zeggen. Wellicht kan @wjb hier te hulp schieten?

Reputatie 7
Badge +24

Het vlan instellen doet u volgens mij in Pfsense zelf. Dat hoeft u niet te doen in een configuratiebestand op de host.

Reputatie 7

De MTU voor vlan 6 moet geen 1512 maar 1508 zijn.

Kan je de definitie van de pppoe interface ook tonen.

thanks, zal het komende dagen ergens gaan testen. Internet in het huis platleggen wordt niet al te veel gewaardeerd dus moet even momentje vinden ;-)

Reputatie 7
Badge +24

Internet in het huis platleggen wordt niet al te veel gewaardeerd dus moet even momentje vinden ;-)

Daarom heb ik Opnsense als 2de router achter het modem van KPN. Dan blijft tv sowieso altijd werken. Want dat zit rechtstreeks op het KPN modem. En in het uiterste geval van nood kan ik het WiFi van het KPN modem ook activeren. Hebben de mobieltjes en laptops in iedergeval internet. 

Opnsense als 2de router bied ook de mogelijkheid om 2 installaties paralel naast elkaar te draaien. 1 voor "productie" en de andere om een beetje op te testen. Nieuwe dingen proberen enzo.

Een ander punt van aandacht is: wat gebeurt er bij een stroomstoring? Start daarna alles weer automatisch op? 

Oke, ik had pfsense op proxmox draaien. Ik ben geswitched naar OPNsense die op dedicated hardware draait. MTU an VLAN 6 op 1508 gezet en pats boem! het werkt.

 

@Nick83 stroomstoring scenario moet je regelen in de bios settings van je hardware device. Er is in een veld (meestal in advanced) waar je kan aangeven wat je device doet na een stroom onderbreking. disable, enable or last state. altijd enable klikken. Als je firewall virtueel is moet je zorgen dat je hypervisor de firewall VPN altijd opstart upon boot

Reputatie 7
Badge +20

Super dat het weer werkt @PrivateBungo 💪🏼 Dank voor je update!

Reageer